Skip to Content

Document Design Manager

Datafile Software

Document Design Manager

The Document Design Manager is available on the main ‘Installation’ menu for Compact and Professional users, for Diamond and Premier users it is available on the ‘Application Manager’ sub-menu.

The document design allows you amend the acknowledgements, delivery notes and invoices for the sales and purchase order processing applications. Select the application and then the document type required, the list of documents is then displayed.

If you want to update an existing document, enter the layout number in the input provided, if you want to create a new document you need to firstly add it to the list by:

Press <F4-Select> to allow amendment of the list.

Find a blank entry and enter the document title.

Enter its definition filename. Filenames usually follow the convention CCC-SPXN.DEF. CCC is the company id and SP indicates a sales order document (so PP for purchase order documents). Xis the document type (A-Acknowledgement, D-Delivery Note and I-Invoice) and N is the layout number 1-9 (use A for 10, B for 11, C for 12 to keep the parameter file to an 8.3 format).

Press <End> to go back to the document layout selection.

Notes

A document definition is held in two files – a filename.DEF listed above contains the document parameter details, and a filename.INI contains the font settings, line and box drawing and image file(s) detail. The INI file is created automatically on first load of the document.

Create Document Based on Existing

If you select the newly added document now, then this creates a blank document, if you want to create the new document based on an existing layout then use the <F7-Option> key to copy the definition from one file to another.

Note you can only copy documents within an application– you cannot copy, for example, an invoicer document as an order processing document.

On input of the layout number you are presented with the document template.

Converting a Document

Previous to release 5.6 documents were designed in a different manner.Whenever you open a document that was designed using the old designer you will be asked to convert to the new layout.

To convert to the new style select ‘Use New Designer’, if you want to continue with the old layouts then select ‘Use Old Designer’. To abandon select the ‘Close’ button. When you use the new designer for the first time a backup copy of the old layout is taken as filename.OLD which you can copy back if needed. If you do this you would need to delete the filename.INI discussed above.

When creating a document for the first time or opening an older style of document you will be prompted for the page set-up details.

Paper Size – offers a drop-down list of paper sizes available. Select the paper size appropriate.

Page Width (mm) / Height (mm) – if select custom page size enter the width / height required. Otherwise if select standard page size then these inputs display the page size.

Print in Landscape– set whether the document is to be printed in landscape. Leave blank to print in portrait.

No of Columns Across / No of Lines Down – if converting an older document this defaults to values as previously defined on the document - typically you would leave these values as set for your document. For new documents this will default to 80 columns across and 66 lines down and you can amend as required.

These values can be amended up to 255 columns across and 132 lines down. The columns and line values form a ‘design grid’ on the document with the no of columns set controlling the number of grid start points across the page, the lines down controlling the grid points down the page (think graph paper). Text, Image and Lines do not have to start at a grid point but data items do – increasing the number of columns / grid points across the page gives you more flexibility with regards to data item positioning.

Take care on increasing this value on existing documents as items starting at a particular column/grid point may overlap if you increase the number of columns. With regards to the number of lines down, again take care increasing this value on existing documents as line items may overlap. In addition though increasing this value too far may cause the print of detail lines to overlap if the font of detail items selected for print is bigger than the line height.

Start Detail Line / End Detail Line – if converting an older document this defaults to values as previously defined on the document - typically you would leave these values as set. When opening a new document this will default so that a quarter of the page acts as the header and a quarter of the page is the footer – the balance being the detail area.

Margins – next you can set, in millimetres, the left, right, and top and bottom margins.

When you print a document each printer has its own internal set margin and the grid (discussed above) is fitted within this. If printing a document on multiple printers, especially when using pre-printed stationery, you should set the margins on the document equal to or greater than the largest margin of the printer(s), to ensure identical print on all printers.The Install menu on the toolbar allows the option ‘View Printers’ which enables you to perform a test print which shows the print margins (as a border on the page).

Notes

The Install menu on the toolbar (desktop) is only available for the SYSTEM user-id and for Premier users set to use the ‘Installer’ desktop.

Once you have set/confirmed the margins the document mask is displayed.

A document is split into three sections – a header, a detail and a footer area as mentioned above. In statements the header area is used to print details of the customer/supplier. The detail section prints, line-by-line, the order detail breakdown.The footer area shows totals such as the VAT analysis and document totals, etc.

The Document Design Toolbar

Before discussing the specifics of designing a document, you should review the document design toolbar.

The toolbar has the options – File, Edit, Tools, Parameters and Format. Each of these (other than Parameters) offers a list of actions available.

The File menu has options to save the document layout, amend/view the page set-up, preview the design to the screen, perform a test print of the document, and exit out of the document design (you will be prompted to save if you haven’t already done so).

The Edit menu has options that are only available when an item on the document is selected. You can cut an object out of the design, copy an item (except data items), or delete an item. You can also insert a line above the selected item or delete a line with the selected item on.

The Tools menu has options to restructure a database, refresh the display, and controls for whether you show the data items (you may want to switch this off to position text behind it), whether you show the grid, and whether new text/line/image items are to be positioned at the start of the grid.

The Format option allows you to select a bitmap image to act as a watermark behind the page detail, set and applies font defaults, and configure printer, email and fax settings.

The Parameters option loads the first of the parameter screens available for this document.

Setting and Applying Font Defaults

Before you start to design your document you may wish to set default fonts for each area of the document.You can amend the fonts for each item individually but initially you are likely to want to assign a default font for all items in a specified area.

Each document has three areas – header, detail and footer. The detail area starts two lines above the start detail line (to encompass column headings for the details) and finishes at the end detail line. The header area is above the detail area, the footer below. The only documents that don’t follow this format are purchase cheque layouts, payroll and invoice generator documents which don’t have set detail area – on these documents the ‘header’ area encompasses the entire page.

Converting an Existing Document

When you convert an older style document a font of Courier New is assigned to the existing data and text items. You can use the Font Default options to reset the font/size of these items as required.

In the earlier designer text was created on the document by positioning the cursor and typing the required text. In converting this into the text labels of this new designer the assumption is made that text separated by a single space is part of the same label, more than one space and two (or more) separate labels are created. In this way the text heading on the document of (say) ‘S A L E S I N V O I C E’ is converted as two labels one for ‘S A L E S’ and one for ‘I N V O I C E’ as the two words were separated by three spaces in the old designer.

To set and apply default fonts select the Format option from the toolbar, choose Font Defaults and then the area you wish to apply the fonts to – a dialog box will be displayed enabling you to select the font, style and size.

You can scroll up/down the list of fonts, use the mouse to select the required option (once selected the chosen value will be updated at the top of the list). After selecting the font, select the style and then the size. You can also amend the colour of the text if required. Once you have selected the required details press OK.

After selecting the font you can control whether it applies to the text items or the data items in the defined area (or both or indeed neither – you might set a default because the next x items you are going to insert all use a specific font). Tick the options required and click the APPLY button.

Once you have set and applied the default fonts you can then adjust the font and size of individual items as required.

If you have need to reset all items to the set default fonts then choosing the Apply Fonts option available from the Format pull-down allows this.

  • Release ID: Standard